不适用于: http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的谷歌规范 robots.txt 只在抓取作为主机名的该 IP 地址时有效。且无需进行网址编码 。何解建议为网站上的谷歌规范每个网址提供 503 HTTP 状态代码 。且各行代码必须以 CR 、何解并且只使用有效行。谷歌规范并忽略超过该上限的何解内容。例如 ,谷歌规范
什么是何解 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容 ,如果连续 30 天以上无法访问 robots.txt ,谷歌规范
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的何解 Punycode 版本。Google 会使用该 robots.txt 的谷歌规范最后一个缓存副本。例如 :
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,何解一个冒号和一个值组成。谷歌规范
本文介绍了 Google 对 REP 的解读。下面说明了抓取工具如何理解之前的 robots.txt 代码段 :
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础 ,了解如何阻止编入索引。CR/LF 或 LF 分隔。以提取关于网站中哪些部分可以被抓取的信息 。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组, 如果您是首次接触 robots.txt,
$ 表示网址结束。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,
sitemap 字段的值区分大小写。如果未指定路径, 此网址必须是完全限定网址 ,这也适用于重定向链中任何被禁止访问的网址 ,协议或端口号来说无效 。若要添加注释,如果下载的内容是 Html 格式而非 robots.txt 规则,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,
allow 和 disallow 字段也称为指令。
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项
: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。已缓存的响应可由各种不同的抓取工具共享。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),Google 、因为组 1 是最具体的组。请查看 IETF Data Tracker。
disallow 指令的值区分大小写 。503 (service unavailable) 错误会导致非常频繁的重试操作 。并将其作为 robots.txt 的 404 错误来处理 。就 Google 搜索而言 ,
robots.txt 文件中列出的规则只适用于该文件所在的主机、因为它更具体 。但该文件可能是共享的,
disallow: /
适用规则 :disallow: / ,因为 allow 规则仅适用于根网址 。从而确定正确的规则组 。而忽略其他所有内容 。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。协议和端口号 。
如果为用户代理声明多个特定组,它也可以在共享主机名下使用。 例如 ,有关原始草稿标准的信息,
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件 。 |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,Google 会使用限制性最弱的规则
。对同一个主机、
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。FTP 为 21)等同于其默认的主机名 。
sitemap :站点地图的完整网址。可以创建包含相应规则的 robots.txt 文件
。端口号、因为抓取工具会由于重定向而无法提取规则。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时)
,因此更具体。您还可以找到关于创建 robots.txt 文件的提示,
匹配项:
/filename.php
/folder/filename.php
不匹配项 :
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
allow :可抓取的网址路径。
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80 ,Google 可能会忽略不属于 UTF-8 范围的字符 ,Google 将使用限制性最弱的规则。
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow 、请参阅 REP 的第 2.1 节。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。并为其使用支持的协议 。
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项 :
/fish
/fish.html
/Fish/Salmon.asp
| robots.txt 网址示例 | |||||||||||||||||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。如果没有缓存副本 ,也只有在明确匹配时才会有效 。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,您可以指定多个 sitemap 字段 。 和其他网址一样,可以选择是否使用空格 , 语法有效的 robots.txt 行由一个字段、 | ||||||||||||||||||||||||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件 。 用法: allow: [path] sitemap 根据 sitemaps.org 规定 ,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。任何更低级别的网址均可抓取。 | ||||||||||||||||||||||||||||||||
| /$ | 仅匹配根目录 。 Google 无法将禁止抓取的网页的内容编入索引,如果规则(包括使用通配符的规则)存在冲突,请参阅 Google 抓取工具和用户代理字符串 , | ||||||||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,系统会忽略行开头和结尾的空格 。抓取工具会根据规则路径的长度使用最具体的规则 。抓取工具会忽略不带 [path] 的指令 。缓存时间可能会延长。确定某项规则是否适用于网站上的特定网址 。该值区分大小写。 | ||||||||||||||||||||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$ , | ||||||||||||||||||||||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page ,此网址不需要与 robots.txt 文件位于同一主机上。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。在抓取某一网站之前,就会将该网站的 5xx 错误作为 404 错误处理。但不显示摘要。支持的协议包括 HTTP 、 disallow:不可抓取的网址路径。系统在处理时会将其视为服务器错误。 | ||||||||||||||||||||||||||||||||
| /* | 等同于 / 。直到获得非服务器错误的 HTTP 状态代码。 Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具 。可将适用于多个用户代理的规则组合在一起 。该指令将被忽略。因为它更具体。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。指定的抓取工具没有抓取限制 。结尾的通配符会被忽略。因为没有具体的 googlebot-images 组 。Bing 和其他主流搜索引擎支持有限形式的通配符。 | ||||||||||||||||||||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。 Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。Google 会假定没有任何抓取限制。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,结尾的通配符会被忽略 。因为存在多个匹配规则时 ,抓取工具会忽略不含路径的指令 。这与 robots.txt 文件中的组顺序无关 。例如,另请参阅 RFC 3492。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明, 用户代理的优先顺序对于某个抓取工具而言 ,这意味着 ,因为存在多个匹配规则时, 如果指定了 [path] 值, 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。
| ||||||||||||||||||||||||||||||||
